Zoom Minimum Software Version Requirement Set to Latest Version Beginning Jan. 5

In order to make the Zoom experience consistent across the Case Western Reserve University community, on January 5, the minimum software version requirement will be set to the latest version. Many new features implemented over the past several months require the latest version of the application.

If your Zoom software is not updated by January 5, when you attempt to sign into the client application (versus the web portal) you will be prompted to install the latest version.

To update your desktop Zoom application, click on the profile icon in the top right corner of the application and select "check for updates" from the list. You can also download the latest version from https://zoom.us/download.

For assistance with any technology product or service at Case Western Reserve University, contact the University Technology Service Desk at help@case.edu, 216.368.HELP (4357) or visit help.case.edu.